use strict;
my $str = 'myApp.ComboPlaceHolderLabel,
myApp.GridTitleLabel);
myApp.SummaryLabel + \'</b></div>\');
myApp.NoneLabel + \')\') + \'</label></div>\';';
my $regex = qr/\b[,); +]+.*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";