re = /\b[,); +]+.*$/m
str = 'myApp.ComboPlaceHolderLabel,
myApp.GridTitleLabel);
myApp.SummaryLabel + \'</b></div>\');
myApp.NoneLabel + \')\') + \'</label></div>\';'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result