import re
regex = re.compile(r"\b[,); +]+.*$", flags=re.MULTILINE)
test_str = ("myApp.ComboPlaceHolderLabel,\n"
"myApp.GridTitleLabel);\n"
"myApp.SummaryLabel + '</b></div>');\n"
"myApp.NoneLabel + ')') + '</label></div>';")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)