package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)hello\s+?([^\s]*)\s*|welcome\s+?to\s+?([^\s]*)`)
var str = `Hello Scott, welcome to VietNam
welcome to VietNam, Hello Scott`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}