const regex = new RegExp('hello\\s+?([^\\s]*)\\s*|welcome\\s+?to\\s+?([^\\s]*)', 'gi')
const str = `Hello Scott, welcome to VietNam
welcome to VietNam, Hello Scott`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}