re = /hello\s+?([^\s]*)\s*|welcome\s+?to\s+?([^\s]*)/i
str = 'Hello Scott, welcome to VietNam
welcome to VietNam, Hello Scott'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end