$re = '/hello\s+?([^\s]*)\s*|welcome\s+?to\s+?([^\s]*)/i';
$str = 'Hello Scott, welcome to VietNam
welcome to VietNam, Hello Scott';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);