// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)hello\s+?([^\s]*)\s*|welcome\s+?to\s+?([^\s]*)").unwrap();
let string = "Hello Scott, welcome to VietNam
welcome to VietNam, Hello Scott";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}