using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[:space:]]*([_[:alnum:]]*)[[:space:]]*=[[:space:]]*((.*?)[[:space:]]+([_[:alnum:]]+[[:space:]]*=[[:space:]]*.*))";
string input = @"key1 = what' ever the value key2 = the value Nb.2 key3= ""last value""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}