re = /[[:space:]]*([_[:alnum:]]*)[[:space:]]*=[[:space:]]*((.*?)[[:space:]]+([_[:alnum:]]+[[:space:]]*=[[:space:]]*.*))/
str = 'key1 = what\' ever the value key2 = the value Nb.2 key3= "last value"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end