package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[[:space:]]*([_[:alnum:]]*)[[:space:]]*=[[:space:]]*((.*?)[[:space:]]+([_[:alnum:]]+[[:space:]]*=[[:space:]]*.*))`)
var str = `key1 = what' ever the value key2 = the value Nb.2 key3= "last value"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}