import Foundation
let pattern = #"[[:space:]]*([_[:alnum:]]*)[[:space:]]*=[[:space:]]*((.*?)[[:space:]]+([_[:alnum:]]+[[:space:]]*=[[:space:]]*.*))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"key1 = what' ever the value key2 = the value Nb.2 key3= "last value""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}