// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\d+\]\s(\w+)\s\|\s(\w+)\s\|\s(\w+)\s\|\s(\S+)\s(\S+)\s\|\s(\S+)\s(\S+)\s\|\s(\S+)\s(\S+)").unwrap();
let string = "[1] weight | width | depth | 5.0 cm | 6.0 mm^2 | 10.12 cm^3";
let substitution = "name = $1\\nvalue = $4\\nunit = $5\\n\\nname = $2\\nvalue = $6\\nunit = $7\\n\\nname = $3\\nvalue = $8\\nunit = $9";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}