#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\/\*.*\*\/"
Local $sString = "/* DATA DESCRIPTION:" & @CRLF & _
"" & @CRLF & _
"Citation: Gross, Felix; Kopte, Robert; Schneider, Ralph R (2022): ADCP current measurements (38 kHz) during RV MARIA S. MERIAN cruise MSM101. PANGAEA, https://doi.org/10.1594/PANGAEA.940856" & @CRLF & _
"" & @CRLF & _
"Size: 4824045 data points" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"Date/Time Latitude Longitude Depth water [m]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")