$re = '/\/\*.*\*\//s';
$str = '/* DATA DESCRIPTION:
Citation: Gross, Felix; Kopte, Robert; Schneider, Ralph R (2022): ADCP current measurements (38 kHz) during RV MARIA S. MERIAN cruise MSM101. PANGAEA, https://doi.org/10.1594/PANGAEA.940856
Size: 4824045 data points
*/
Date/Time Latitude Longitude Depth water [m]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);