import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*.*\\*\\/";
final String string = "/* DATA DESCRIPTION:\n\n"
+ "Citation: Gross, Felix; Kopte, Robert; Schneider, Ralph R (2022): ADCP current measurements (38 kHz) during RV MARIA S. MERIAN cruise MSM101. PANGAEA, https://doi.org/10.1594/PANGAEA.940856\n\n"
+ "Size: 4824045 data points\n\n"
+ "*/\n\n"
+ "Date/Time Latitude Longitude Depth water [m]";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}