import Foundation
let pattern = #"\/\*.*\*\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
/* DATA DESCRIPTION:
Citation: Gross, Felix; Kopte, Robert; Schneider, Ralph R (2022): ADCP current measurements (38 kHz) during RV MARIA S. MERIAN cruise MSM101. PANGAEA, https://doi.org/10.1594/PANGAEA.940856
Size: 4824045 data points
*/
Date/Time Latitude Longitude Depth water [m]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)