const regex = /\/\*.*\*\//gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*.*\\*\\\/', 'gs')
const str = `/* DATA DESCRIPTION:
Citation: Gross, Felix; Kopte, Robert; Schneider, Ralph R (2022): ADCP current measurements (38 kHz) during RV MARIA S. MERIAN cruise MSM101. PANGAEA, https://doi.org/10.1594/PANGAEA.940856
Size: 4824045 data points
*/
Date/Time Latitude Longitude Depth water [m]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}