package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((\+|(00))3\d)|0)\d{9}$`)
var str = `OUI
0689553212
0789553212
+33689553212
+32689553212
0033689553212
0032689553212
NON
1234567890
012345678
+3301234567
+3689553212
003301234567
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}