import re
regex = re.compile(r"^(((\+|(00))3\d)|0)\d{9}$", flags=re.MULTILINE)
test_str = ("OUI\n"
"0689553212\n"
"0789553212\n"
"+33689553212\n"
"+32689553212\n"
"0033689553212\n"
"0032689553212\n\n"
"NON\n"
"1234567890\n"
"012345678\n"
"+3301234567\n"
"+3689553212\n"
"003301234567\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")