// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((\+|(00))3\d)|0)\d{9}$").unwrap();
let string = "OUI
0689553212
0789553212
+33689553212
+32689553212
0033689553212
0032689553212
NON
1234567890
012345678
+3301234567
+3689553212
003301234567
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}