$re = '/^(((\+|(00))3\d)|0)\d{9}$/m';
$str = 'OUI
0689553212
0789553212
+33689553212
+32689553212
0033689553212
0032689553212
NON
1234567890
012345678
+3301234567
+3689553212
003301234567
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);