const regex = /^(((\+|(00))3\d)|0)\d{9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((\\+|(00))3\\d)|0)\\d{9}$', 'gm')
const str = `OUI
0689553212
0789553212
+33689553212
+32689553212
0033689553212
0032689553212
NON
1234567890
012345678
+3301234567
+3689553212
003301234567
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}