#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bM[rs]\.(?: (?!M[rs]\.|and )\w+)*"
Local $sString = "Mr. Snow" & @CRLF & _
"Mr. John Snow" & @CRLF & _
"Mr. John Snow (Winterfall of the nord lands)" & @CRLF & _
"Mr. Snow and Ms. Stark" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")