using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bM[rs]\.(?: (?!M[rs]\.|and )\w+)*";
string input = @"Mr. Snow
Mr. John Snow
Mr. John Snow (Winterfall of the nord lands)
Mr. Snow and Ms. Stark
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}