re = /\bM[rs]\.(?: (?!M[rs]\.|and )\w+)*/m
str = 'Mr. Snow
Mr. John Snow
Mr. John Snow (Winterfall of the nord lands)
Mr. Snow and Ms. Stark
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end