import re
regex = re.compile(r"\bM[rs]\.(?: (?!M[rs]\.|and )\w+)*", flags=re.MULTILINE)
test_str = ("Mr. Snow\n"
"Mr. John Snow\n"
"Mr. John Snow (Winterfall of the nord lands)\n"
"Mr. Snow and Ms. Stark\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")