const regex = /^https?:\/\/www\.mangeznotez(dev)?\.com\/booking\/[a-z\d]+\/\d\?giftCardCode=[a-zA-Z\d]{5}/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/www\\.mangeznotez(dev)?\\.com\\\/booking\\\/[a-z\\d]+\\\/\\d\\?giftCardCode=[a-zA-Z\\d]{5}', 'i')
const str = `https://www.mangeznotezdev.com/booking/363acccf265c890fd0134c771ee146b1/1?giftCardCode=f2c63`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}