use strict;
my $str = 'https://www.mangeznotezdev.com/booking/363acccf265c890fd0134c771ee146b1/1?giftCardCode=f2c63';
my $regex = qr/^https?:\/\/www\.mangeznotez(dev)?\.com\/booking\/[a-z\d]+\/\d\?giftCardCode=[a-zA-Z\d]{5}/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}