import Foundation
let pattern = #"^https?:\/\/www\.mangeznotez(dev)?\.com\/booking\/[a-z\d]+\/\d\?giftCardCode=[a-zA-Z\d]{5}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"https://www.mangeznotezdev.com/booking/363acccf265c890fd0134c771ee146b1/1?giftCardCode=f2c63"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}