// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^https?:\/\/www\.mangeznotez(dev)?\.com\/booking\/[a-z\d]+\/\d\?giftCardCode=[a-zA-Z\d]{5}").unwrap();
let string = "https://www.mangeznotezdev.com/booking/363acccf265c890fd0134c771ee146b1/1?giftCardCode=f2c63";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}