#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[A-Za-z]|([,.'-]))(?!(?:.*?\1))){2,} +(?:(?:[A-Za-z]|([,.'-]))(?!(?:.*?\2))){2,}$"
Local $sString = "firstname" & @CRLF & _
"Lastname" & @CRLF & _
"F lastname" & @CRLF & _
"firstname l" & @CRLF & _
"Firstname Lastname,,,,,," & @CRLF & _
"f-name lastname" & @CRLF & _
"someguy en'try" & @CRLF & _
"Patrick O'Brian" & @CRLF & _
"web dev@" & @CRLF & _
"'f names" & @CRLF & _
"'f names," & @CRLF & _
"Mr. Bean" & @CRLF & _
"Mr.. Bean" & @CRLF & _
".hidden file" & @CRLF & _
".hidden. file"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")