using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[A-Za-z]|([,.'-]))(?!(?:.*?\1))){2,} +(?:(?:[A-Za-z]|([,.'-]))(?!(?:.*?\2))){2,}$";
string input = @"firstname
Lastname
F lastname
firstname l
Firstname Lastname,,,,,,
f-name lastname
someguy en'try
Patrick O'Brian
web dev@
'f names
'f names,
Mr. Bean
Mr.. Bean
.hidden file
.hidden. file";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}