import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[A-Za-z]|([,.'-]))(?!(?:.*?\\1))){2,} +(?:(?:[A-Za-z]|([,.'-]))(?!(?:.*?\\2))){2,}$";
final String string = "firstname\n"
+ "Lastname\n"
+ "F lastname\n"
+ "firstname l\n"
+ "Firstname Lastname,,,,,,\n"
+ "f-name lastname\n"
+ "someguy en'try\n"
+ "Patrick O'Brian\n"
+ "web dev@\n"
+ "'f names\n"
+ "'f names,\n"
+ "Mr. Bean\n"
+ "Mr.. Bean\n"
+ ".hidden file\n"
+ ".hidden. file";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}