const regex = /^(?:(?:[A-Za-z]|([,.'-]))(?!(?:.*?\1))){2,} +(?:(?:[A-Za-z]|([,.'-]))(?!(?:.*?\2))){2,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[A-Za-z]|([,.\'-]))(?!(?:.*?\\1))){2,} +(?:(?:[A-Za-z]|([,.\'-]))(?!(?:.*?\\2))){2,}$', 'gm')
const str = `firstname
Lastname
F lastname
firstname l
Firstname Lastname,,,,,,
f-name lastname
someguy en'try
Patrick O'Brian
web dev@
'f names
'f names,
Mr. Bean
Mr.. Bean
.hidden file
.hidden. file`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}