$re = '/^(?:(?:[A-Za-z]|([,.\'-]))(?!(?:.*?\1))){2,} +(?:(?:[A-Za-z]|([,.\'-]))(?!(?:.*?\2))){2,}$/m';
$str = 'firstname
Lastname
F lastname
firstname l
Firstname Lastname,,,,,,
f-name lastname
someguy en\'try
Patrick O\'Brian
web dev@
\'f names
\'f names,
Mr. Bean
Mr.. Bean
.hidden file
.hidden. file';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);