# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?=(.*)\b(?:19[2-9]|20[0-2])\d\b)/ /gm;t' <<< "This.Is.The.Movie.Title.1930.details.of
This.Is.The.Movie.Title.2013.details
This.Is.The.Movie.Title.1919.details.of (year too early)
This.Is.The.Movie.Title.2030.details.of (year too late)
This.Is.The.Movie.Title.201.details.of (too few year digits)
This.Is.The.Movie.Title.20000.details.of (too many year digits)
"