const regex = /\.(?=(.*)\b(?:19[2-9]|20[0-2])\d\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?=(.*)\\b(?:19[2-9]|20[0-2])\\d\\b)', 'gm')
const str = `This.Is.The.Movie.Title.1930.details.of
This.Is.The.Movie.Title.2013.details
This.Is.The.Movie.Title.1919.details.of (year too early)
This.Is.The.Movie.Title.2030.details.of (year too late)
This.Is.The.Movie.Title.201.details.of (too few year digits)
This.Is.The.Movie.Title.20000.details.of (too many year digits)
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);