using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?=(.*)\b(?:19[2-9]|20[0-2])\d\b)";
string substitution = @" ";
string input = @"This.Is.The.Movie.Title.1930.details.of
This.Is.The.Movie.Title.2013.details
This.Is.The.Movie.Title.1919.details.of (year too early)
This.Is.The.Movie.Title.2030.details.of (year too late)
This.Is.The.Movie.Title.201.details.of (too few year digits)
This.Is.The.Movie.Title.20000.details.of (too many year digits)
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}