import Foundation
let pattern = #"\.(?=(.*)\b(?:19[2-9]|20[0-2])\d\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This.Is.The.Movie.Title.1930.details.of
This.Is.The.Movie.Title.2013.details
This.Is.The.Movie.Title.1919.details.of (year too early)
This.Is.The.Movie.Title.2030.details.of (year too late)
This.Is.The.Movie.Title.201.details.of (too few year digits)
This.Is.The.Movie.Title.20000.details.of (too many year digits)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)