import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(?=(.*)\\b(?:19[2-9]|20[0-2])\\d\\b)";
final String string = "This.Is.The.Movie.Title.1930.details.of\n"
+ "This.Is.The.Movie.Title.2013.details\n\n"
+ "This.Is.The.Movie.Title.1919.details.of (year too early)\n"
+ "This.Is.The.Movie.Title.2030.details.of (year too late)\n"
+ "This.Is.The.Movie.Title.201.details.of (too few year digits)\n"
+ "This.Is.The.Movie.Title.20000.details.of (too many year digits)\n";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}