#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(1 )?(\d{3}|\(\d{3}\))[\- ]?\d{3}[\- ]?\d{4}$"
Local $sString = "below for other variants):" & @CRLF & _
"" & @CRLF & _
"555-555-5555" & @CRLF & _
"" & @CRLF & _
"(555)555-5555" & @CRLF & _
"" & @CRLF & _
"(555) 555-5555" & @CRLF & _
"" & @CRLF & _
"555 555 5555" & @CRLF & _
"" & @CRLF & _
"5555555555" & @CRLF & _
"" & @CRLF & _
"1 555 555 5555" & @CRLF & _
"" & @CRLF & _
"this is what i tried" & @CRLF & _
"lse for any case that don't match those above like : " & @CRLF & _
"10 (757) 622-7382" & @CRLF & _
" or " & @CRLF & _
"555)-555-5555"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")