re = /^(1 )?(\d{3}|\(\d{3}\))[\- ]?\d{3}[\- ]?\d{4}$/m
str = 'below for other variants):
555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
this is what i tried
lse for any case that don\'t match those above like :
10 (757) 622-7382
or
555)-555-5555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end