const regex = /^(1 )?(\d{3}|\(\d{3}\))[\- ]?\d{3}[\- ]?\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(1 )?(\\d{3}|\\(\\d{3}\\))[\\- ]?\\d{3}[\\- ]?\\d{4}$', 'gm')
const str = `below for other variants):
555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
this is what i tried
lse for any case that don't match those above like :
10 (757) 622-7382
or
555)-555-5555`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}