$re = '/^(1 )?(\d{3}|\(\d{3}\))[\- ]?\d{3}[\- ]?\d{4}$/m';
$str = 'below for other variants):
555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
this is what i tried
lse for any case that don\'t match those above like :
10 (757) 622-7382
or
555)-555-5555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);