import re
regex = re.compile(r"^(1 )?(\d{3}|\(\d{3}\))[\- ]?\d{3}[\- ]?\d{4}$", flags=re.MULTILINE)
test_str = ("below for other variants):\n\n"
"555-555-5555\n\n"
"(555)555-5555\n\n"
"(555) 555-5555\n\n"
"555 555 5555\n\n"
"5555555555\n\n"
"1 555 555 5555\n\n"
"this is what i tried\n"
"lse for any case that don't match those above like : \n"
"10 (757) 622-7382\n"
" or \n"
"555)-555-5555")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")