#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)Block (\d+) start.+Block \1 end"
Local $sString = "Block 1 start" & @CRLF & _
"Line 1 in Block 1" & @CRLF & _
"Line 2 in Block 1" & @CRLF & _
"Block 1 end" & @CRLF & _
"" & @CRLF & _
"Block 2 start" & @CRLF & _
"Line 1 in Block 2" & @CRLF & _
"" & @CRLF & _
"Block 3 start" & @CRLF & _
"Line 1 in Block 3" & @CRLF & _
"Block 3 end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")