import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)Block (\\d+) start.+Block \\1 end";
final String string = "Block 1 start\n"
+ "Line 1 in Block 1\n"
+ "Line 2 in Block 1\n"
+ "Block 1 end\n\n"
+ "Block 2 start\n"
+ "Line 1 in Block 2\n\n"
+ "Block 3 start\n"
+ "Line 1 in Block 3\n"
+ "Block 3 end";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}