re = /(?s)Block (\d+) start.+Block \1 end/m
str = 'Block 1 start
Line 1 in Block 1
Line 2 in Block 1
Block 1 end
Block 2 start
Line 1 in Block 2
Block 3 start
Line 1 in Block 3
Block 3 end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end