using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)Block (\d+) start.+Block \1 end";
string input = @"Block 1 start
Line 1 in Block 1
Line 2 in Block 1
Block 1 end
Block 2 start
Line 1 in Block 2
Block 3 start
Line 1 in Block 3
Block 3 end";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}